View unanswered posts | View active topics It is currently December 1st, 2020, 1:26 am



Reply to topic  [ 4 posts ] 
 Oil Light Not Working 
Author Message
Firing on two.

Joined: June 22nd, 2014, 8:09 pm
Posts: 743
Location: Reading, Berks UK
Post Oil Light Not Working
Friends, my oil light doesn't work. It may be because my ignition wires all fell off while I was driving recently and I stuck them back on but maybe they're wrong.

Any chance of a picture of how the wires connect on the back on the ignition switch off a late special?

The bulb itself is fine when connected to the hazard connections.


September 25th, 2020, 7:14 pm
Profile
Firing on two.
User avatar

Joined: March 21st, 2013, 12:04 am
Posts: 1131
Location: Exeter, Devon
Post Re: Oil Light Not Working
the circuit itself is very simple.

A switched 12v supply to the bulb. A wire from the bulb to the oil pressure sender. The sender switches the ground side of the circuit.when there is pressure, the sender breaks the circuit

The oil pressure sender, is not to far from the points box, and the wire for it goes through the front of the fan cowling with the wire that goes to the points box.

If you follow those wires up from the bottom of the cowling to the headlight bar, you will most lightly find a disconnected wire. Somewhere in the wiring harness suppling the lights and coil etc, is a wire without anything plugged in. Its most lighly dropped down if you cant see it. :)

Whilst testing, dont burn your coil out by leaving the ignition switched on constantly. ;)

_________________
If you can't fix it with a hammer, it's probably electrical (or, an electric fuel pump!) ....


September 26th, 2020, 12:41 pm
Profile
Firing on two.

Joined: June 22nd, 2014, 8:09 pm
Posts: 743
Location: Reading, Berks UK
Post Re: Oil Light Not Working
Thanks Roger. I feel like it coincided with the ignition wires falling off, but I'll investigate from the sensor up. I replaced that one a few years ago so I know where it lives.


September 28th, 2020, 11:02 am
Profile
Firing on two.

Joined: June 22nd, 2014, 8:09 pm
Posts: 743
Location: Reading, Berks UK
Post Re: Oil Light Not Working
Thanks Roger I'll check it out. I did replace that sensor a few years ago so I know the one.


October 2nd, 2020, 7:29 pm
Profile
Display posts from previous:  Sort by  
Reply to topic   [ 4 posts ] 

Who is online

Users browsing this forum: No registered users and 23 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
cron
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group.
Designed by STSoftware for PTF.